Jump to content


Photo
- - - - -

ROCCAT Tyon - Macro Software Doesn't Allow You To Map A Mouse Button To A Macro Key


  • Please log in to reply
2 replies to this topic

#1 tackyjan

tackyjan

    Member

  • Members
  • PipPip
  • 16 posts


Anyone here have a ROCCAT mouse and are familiar with their software.

I am trying to assign a mouse click (right mouse button) to a macro button. There is an option to add a "Shortcut" but it only lets you assign keyboard keys to this shortcut not mouse buttons.

The only way I have figured out how to assign mouse buttons is to create a macro with Right Mouse Button Down / Up events then instead of assigning a "Shortcut" to the mouse macro button I assign the macro.

You might think that's all well and good but there is one issue.
smile.gif


If i assign a keyboard key using a "Shortcut" then press that macro button the longer I hold it down the faster the key event is sent. I am not sure if it accelerates forever but it does so long enough to be very useful.

If I assign the Right Mouse Click macro to a macro button and hold it down it plays at the same interval no matter how long I hold down the button.

In summary, does someone know if there is a fast/easy way to assign the Right Mouse Button to a mouse macro key without using a macro?

Thank you,

Jan


r1_zpsg1clwiu9.png


r2_zpsyuibwfy6.png

#2 tackyjan

tackyjan

    Member

  • Members
  • PipPip
  • 16 posts


I was also wondering if there was a way I could configure the playback so it either repeats while the button is being held or it starts looping when the button is pressed and stops looping when the button is pressed again.

I can't seem to find that functionality either.
Posted Image


Jan



#3 alphataru

alphataru

    Newbie

  • Members
  • Pip
  • 2 posts
Since we're talking about Roccat software, I wanna piggyback. Does the software lag like hell to anyone else? I've had a Tyon and ran the software on Win 8 and Win 10, and whenever I change a setting and hit apply, the software noticeable freezes for 10-30s then the change happens. It's quite annoying, and I'm wondering if other people observed the same thing.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users